hdu-----(3746)Cyclic Nacklace(kmp)

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2716    Accepted Submission(s): 1244

Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:
hdu-----(3746)Cyclic Nacklace(kmp)
Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

 
Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 
Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 
Sample Input
3
aaa
abca
abcde
 
Sample Output
0
2
5
 
Author
possessor WC
 
Source
 
Recommend
 
代码:
     /*
类是于这样的题,其实关键还是再考察对next数组的理解
next数组就是一种关于字符串的前缀数组。
同时需要明白的 是: j-next[j]=len表示的是他的回溯的最大长度
也可以理解为:最小的循环长度。
所以在做这题是,我们需要求出最少需要补偿多少个字符,是她形成
完美的字符串: abcdeab -->next[0~~6]= -1,0,0,0,0,1,2
所以我们可以得到: max_huisuo=7-next[7]=5;
所以我们需要补偿的数为: mx_huisuo -7%5=3; //比如abcdeab-->cde
*/ #include<iostream>
#include<cstring>
#include<cstdlib>
#include<cstdlib>
using namespace std;
const int maxn=;
int next[maxn];
char str[maxn];
int main()
{
int test,i,j,ans;
scanf("%d",&test);
while(test--)
{
scanf("%s",str);
j=-;
i=;
next[i]=-;
int len=strlen(str);
while(i<len)
{
if(j==-||str[i]==str[j])
{
i++;
j++;
if(str[i]==str[j])
next[i]=next[j];
else next[i]=j;
}
else j=next[j];
}
//得到最大回缩长度(即最小循环长度;
int cir_len=len-next[len];
if(cir_len!=len&&==(len%cir_len)) ans=;
else ans=cir_len - len%cir_len ;
printf("%d\n",ans);
}
return ;
}
上一篇:Spring MVC 5 + Thymeleaf 基于Java配置和注解配置


下一篇:干货 | 基于Go SDK操作京东云对象存储OSS的入门指南