1.链接地址:
http://bailian.openjudge.cn/practice/2810/
http://bailian.openjudge.cn/practice/1543/
http://poj.org/problem?id=1543
2.题目:
Perfect Cubes
Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 13190 Accepted: 6995 Description
For hundreds of years Fermat's Last Theorem, which stated simply that for n > 2 there exist no integers a, b, c > 1 such that a^n = b^n + c^n, has remained elusively unproven. (A recent proof is believed to be correct, though it is still undergoing scrutiny.) It is possible, however, to find integers greater than 1 that satisfy the "perfect cube" equation a^3 = b^3 + c^3 + d^3 (e.g. a quick calculation will show that the equation 12^3 = 6^3 + 8^3 + 10^3 is indeed true). This problem requires that you write a program to find all sets of numbers {a,b,c,d} which satisfy this equation for a <= N.Input
One integer N (N <= 100).Output
The output should be listed as shown below, one perfect cube per line, in non-decreasing order of a (i.e. the lines should be sorted by their a values). The values of b, c, and d should also be listed in non-decreasing order on the line itself. There do exist several values of a which can be produced from multiple distinct sets of b, c, and d triples. In these cases, the triples with the smaller b values should be listed first.Sample Input
24Sample Output
Cube = 6, Triple = (3,4,5)
Cube = 12, Triple = (6,8,10)
Cube = 18, Triple = (2,12,16)
Cube = 18, Triple = (9,12,15)
Cube = 19, Triple = (3,10,18)
Cube = 20, Triple = (7,14,17)
Cube = 24, Triple = (12,16,20)Source
3.思路:
枚举+打表(减少计算次数)
注意a要升序排列,然后b,c,d再升序排列
4.代码:
#include <iostream>
#include <cstdio> #define START_N 2 using namespace std; int main()
{
int n;
cin>>n; int *arr_cube = new int[n]; int i,j,k,p;
for(i = START_N; i <= n; ++i)
{
arr_cube[i - START_N] = i * i * i;
for(j = START_N; j <= i; ++j)
{
for(k = j; k <= i; ++k)
{
for(p = k; p <= i; ++p)
{
if(arr_cube[i - START_N] == arr_cube[j - START_N]
+ arr_cube[k - START_N] + arr_cube[p - START_N])
{
cout<<"Cube = "<<i<<", Triple = ("<<j<<","<<k<<","<<p<<")"<<endl;
}
}
}
} } delete [] arr_cube;
return ;
}