UVA122-Trees on the level(链二叉树)

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Submit Status

Description

UVA122-Trees on the level(链二叉树)
 

Background

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.

The Problem

Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree

UVA122-Trees on the level(链二叉树)

is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's andR's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

The Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

The Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed.

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete
题解:
题意很简单,就是给你一棵二叉树,让你从高到低,从左到右输出来;
为什么要用链表,由于256组数据,当节点全在最左枝上的时候,普通二叉树的值是1<<255这么大的数用大数才能保存,所以要考虑用链表来实现;
因为head没有申请内存错了半天,又因为竟然还有(,)()这组数据,还需要加个failed来判断这种情况。。。。不过最后终于ac了;
代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
using namespace std;
const int MAXN=10010;
int ans[MAXN],flot,k;
bool failed;
struct Node{
bool h_v;
int v;
Node *L,*R;
Node():h_v(false),L(NULL),R(NULL){}
}*head;
void addnode(int v,char *s){
//printf("%s %d\n",s,v);
Node *cur=head;
for(int i=0;s[i];i++){
if(s[i]=='L'){
if(cur->L==NULL)cur->L=new Node();
cur=cur->L;
}
else if(s[i]=='R'){
if(cur->R==NULL)cur->R=new Node();
cur=cur->R;
}
}
if(cur->h_v)failed=true;//注意要加上failed判断没有出现数字的情况;
cur->v=v;
cur->h_v=true;
}
void print(){
queue<Node*>q;
Node *cur=head;
q.push(head);
while(!q.empty()){
cur=q.front();
q.pop();
if(cur->h_v==0)flot=0;
if(!flot)break;
ans[k++]=cur->v;
if(cur->L!=NULL)q.push(cur->L);
if(cur->R!=NULL)q.push(cur->R);
}
if(flot&&!failed)for(int i=0;i<k;i++){
if(i)printf(" ");
printf("%d",ans[i]);
}
else printf("not complete");
puts("");
}
void freenode(Node *cur){
if(cur==NULL)return;
freenode(cur->L);
freenode(cur->R);
free(cur);
}
int main(){
char s[MAXN];
head=new Node();
failed=false;
while(~scanf("%s",s)){
if(!strcmp(s,"()")){
flot=1;
k=0;
print();
freenode(head);
head=new Node();
failed=false;
continue;
}
int v;
sscanf(&s[1],"%d",&v);
addnode(v,strchr(s,',')+1);
}
return 0;
}

  

上一篇:Node.js 事件


下一篇:[WebGL入门]十,矩阵计算和外部库