Just a Hook
Time Limit: 1 Sec Memory Limit: 256 MB
题目连接
http://acm.hdu.edu.cn/showproblem.php?pid=1698
Description
Now Pudge wants to do some operations on the hook.
Let
us number the consecutive metallic sticks of the hook from 1 to N. For
each operation, Pudge can change the consecutive metallic sticks,
numbered from X to Y, into cupreous sticks, silver sticks or golden
sticks.
The total value of the hook is calculated as the sum of
values of N metallic sticks. More precisely, the value for each kind of
stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
Input
For each
case, the first line contains an integer N, 1<=N<=100,000, which
is the number of the sticks of Pudge’s meat hook and the second line
contains an integer Q, 0<=Q<=100,000, which is the number of the
operations.
Next Q lines, each line contains three integers X, Y,
1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation:
change the sticks numbered from X to Y into the metal kind Z, where Z=1
represents the cupreous kind, Z=2 represents the silver kind and Z=3
represents the golden kind.
Output
Sample Input
1
10
2
1 5 2
5 9 3
Sample Output
HINT
题意
区间更新为定值,然后问你区间和为多少
题解:
啊,线段树加懒操作,套版
代码:
#include <stdio.h>
#include <string.h> const int MAXN = ;
int sum[MAXN<<];
int lazy[MAXN<<]; void pushup(int rt)
{
sum[rt] = sum[rt<<] + sum[rt<<|];
} void pushdown(int rt, int x)
{
if(lazy[rt] != -) {
lazy[rt<<] = lazy[rt<<|] = lazy[rt];
sum[rt<<] = (x-(x>>))*lazy[rt];///!!!
sum[rt<<|] = (x>>)*lazy[rt];///!!!
lazy[rt] = -;
}
} void creat(int l, int r, int rt)
{
lazy[rt] = -, sum[rt] = ;
if(l == r) return;
int mid = (l+r)>>;
creat(l, mid, rt<<);
creat(mid+, r, rt<<|);
pushup(rt);
} void modify(int l, int r, int x, int L, int R, int rt)
{
if(l <= L && r >= R) {
lazy[rt] = x;
sum[rt] = x*(R-L+);///!!!
return;
}
pushdown(rt, R-L+);///!!!
int mid = (L+R)>>;
if(l <= mid) modify(l, r, x, L, mid, rt<<);
if(r > mid) modify(l, r, x, mid+, R, rt<<|);
pushup(rt);
} int main()
{
int i, j, k = ;
int n, T, q;
int x, y, w;
while(scanf("%d", &T) != EOF)
while(T--)
{
scanf("%d %d", &n, &q);
creat(, n, ); while(q--) {
scanf("%d %d %d", &x, &y, &w);
modify(x, y, w, , n, );
} printf("Case %d: The total value of the hook is %d.\n", ++k, sum[]);
}
return ;
}