全球变暖
你有一张某海域NxN像素的照片,".“表示海洋、”#"表示陆地,如下所示:
……
.##…
.##…
…##.
…####.
…###.
……
其中"上下左右"四个方向上连在一起的一片陆地组成一座岛屿。例如上图就有2座岛屿。
由于全球变暖导致了海面上升,科学家预测未来几十年,岛屿边缘一个像素的范围会被海水淹没。具体来说如果一块陆地像素与海洋相邻(上下左右四个相邻像素中有海洋),它就会被淹没。
例如上图中的海域未来会变成如下样子:
……
……
……
……
….#…
……
……
请你计算:依照科学家的预测,照片中有多少岛屿会被完全淹没。
【输入格式】
第一行包含一个整数N。 (1 <= N <= 1000)
以下N行N列代表一张海域照片。
照片保证第1行、第1列、第N行、第N列的像素都是海洋。
【输出格式】
一个整数表示答案。
1
【输入样例】
7
…
.##…
.##…
…##.
…####.
…###.
…
【输出样例】
1
解析
典型的bfs,但是从哪一点开始搜索呢,想必这是很多人会考虑的问题.如何一次遍历整张图找出所有岛屿?
刚开始我也陷入了这个圈,在想能不能搜索湖逆推岛的数量,但是后来才想到,湖和岛其实是等价的!!!(湖心岛和岛中湖),因此只能在一次bfs搜索完成后,从下一个点继续搜索.
代码
package algorithm;
import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;
/**
* 全球变暖
*
* @author Administrator
*
*/
class Location {
int x;
int y;
char type;
public Location(int x, int y, char type) {
this.x = x;
this.y = y;
this.type = type;
}
}
public class Train24 {
static int N;
static char map[][];// 地图
static boolean visit[][];// 是否已访问
static Queue<Location> queue = new LinkedList<>();// bfs队列
// 左下右上
static int move[][] = { { -1, 0 }, { 0, 1 }, { 1, 0 }, { 0, -1 } };
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
N = scanner.nextInt();
scanner.nextLine();
// 预读地图
String preMap[] = new String[N];
visit = new boolean[N][N];
for (int i = 0; i < N; i++) {
preMap[i] = scanner.nextLine();
}
//修改成char型
map = new char[N][N];
for (int i = 0; i < N; i++) {
for (int j = 0; j < N; j++) {
map[i][j] = preMap[i].charAt(j);
}
}
// 涨水之前岛的数量和涨水之后岛的数量
int count[] = { 0, 0 };
//遍历所有点
for (int i = 0; i < N; i++) {
for (int j = 0; j < N; j++) {
boolean[] flags = bfs(i, j);
if (flags[0]) {
count[0]++;
}
if (flags[1]) {
count[1]++;
}
}
}
System.out.println(count[0] - count[1]);
scanner.close();
}
/**
* bfs
* @param x
* @param y
* @return
*/
public static boolean[] bfs(int x, int y) {
// 一次bfs 找出一个岛
boolean flags[] = { false, false };
if (!check(x, y)) {
// 如果检验访问过 或者不是陆地
return flags;
}
// 未访问过且是陆地
flags[0] = true;
queue.add(new Location(x, y, map[x][y]));
visit[x][y] = true;
while (!queue.isEmpty()) {
Location remove = queue.remove();
for (int i = 0; i < 4; i++) {
int aftX = remove.x + move[i][0];
int aftY = remove.y + move[i][1];
if (check(aftX, aftY)) {
visit[aftX][aftY] = true;
Location location = new Location(aftX, aftY, map[aftX][aftY]);
// 如果该陆地之前没有不被淹没点且当前点不会被淹没
if (!flags[1] && !checkFlood(aftX, aftY)) {
flags[1] = true;
}
queue.add(location);
}
}
}
return flags;
}
/**
* 检验点x,y会不会被淹没
*
* @param x
* @param y
* @return
*/
public static boolean checkFlood(int x, int y) {
for (int i = 0; i < 4; i++) {
if (map[x + move[i][0]][y + move[1][1]] == '.') {
return true;
}
}
return false;
}
/**
* bfs 检验
*
* @param x
* @param y
* @return
*/
public static boolean check(int x, int y) {
return x >= 0 && x < N && y >= 0 && y < N && !visit[x][y] && map[x][y] != '.';
}
}
参考文章
2018年第九届蓝桥杯【C++省赛B组】【第九题:全球变暖】
YanBobo1 发布了10 篇原创文章 · 获赞 0 · 访问量 97 私信 关注