信息学奥赛一本通1354 括弧匹配检验(栈)

1354:括弧匹配检验


时间限制: 1000 ms         内存限制: 65536 KB
提交数: 17618     通过数: 5687

【题目描述】

假设表达式中允许包含两种括号:圆括号和方括号,其嵌套的顺序随意,如([ ]())[([ ][ ])]等为正确的匹配,[( ])([ ]( ) ( ( ) ) )均为错误的匹配。

现在的问题是,要求检验一个给定表达式中的括弧是否正确匹配?

输入一个只包含圆括号和方括号的字符串,判断字符串中的括号是否匹配,匹配就输出 “OK” ,不匹配就输出“Wrong”。输入一个字符串:[([][])],输出:OK

【输入】

输入仅一行字符(字符个数小于255255)。

【输出】

匹配就输出 “OK” ,不匹配就输出“Wrong”。

【输入样例】

[(])

【输出样例】

Wrong

与一本通1353题类似,遇到 ( 或 [ 将其入栈,

遇到 ) 判断栈顶元素是否为 ( ,若是则弹出栈顶元素,若不是则括号不匹配,

遇到 ] 判断栈顶元素是否为 [ ,若是则弹出栈顶元素,若不是则括号不匹配

#include <iostream>
#include <stack>
#include <cstdio>
#include <string>
using namespace std;

stack <char> s;

int main()
{
	string str;
	getline(cin, str);
	int len = str.length(), cnt = 1;
	char c;
	for (int i = 0; i < len; i ++) {
		if (str[i] == '(' || str[i] == '[') {
			s.push(str[i]);
		}
		else if (str[i] == ')') {
			if (s.empty()) {
				cnt = 0; // 用来标记是否匹配,下同
				break;
				// cout << "Wrong" << endl; // 或者直接输出Wrong后return 0;
				// return 0;
			}
			c = s.top();
			if (c == '(') {
				s.pop();
			}
			else {
				cnt = 0; // 用来标记
				break;
				// cout << "Wrong" << endl; // 或者直接输出Wrong后return 0;
				// return 0;
			}
		}
		else if (str[i] == ']') {
			if (s.empty()) {
				cnt = 0; // 用来标记
				break;
				// cout << "Wrong" << endl; // 或者直接输出Wrong后return 0;
				// return 0;
			}
			c = s.top();
			if (c == '[') {
				s.pop();
			}
			else {
				cnt = 0; // 用来标记
				break;
				// cout << "Wrong" << endl; // 或者直接输出Wrong后return 0;
				// return 0;
			}
		}
	}
	if (s.empty() && cnt != 0) {
		cout << "OK" << endl;
	}
	else {
		cout << "Wrong" << endl;
	}
	return 0;
}

用字符组模拟栈

#include <iostream>
#include <stack>
#include <cstdio>
#include <string>
using namespace std;

int main()
{
	char s[1005];
	string str;
	getline(cin, str);
	int len = str.length(), cnt = 1, tmp = 0;
	char c;
	for (int i = 0; i < len; i ++) {
		if (str[i] == '(' || str[i] == '[') {
			s[tmp++] = str[i];
		}
		else if (str[i] == ')') {
			if (tmp == 0) {
				cnt = 0; // 用来标记是否匹配,下同
				break;
				// cout << "Wrong" << endl; // 或者直接输出Wrong后return 0;
				// return 0;
			}
			c = s[tmp-1];
			if (c == '(') {
				tmp --;
			}
			else {
				cnt = 0; // 用来标记
				break;
				// cout << "Wrong" << endl; // 或者直接输出Wrong后return 0;
				// return 0;
			}
		}
		else if (str[i] == ']') {
			if (tmp == 0) {
				cnt = 0; // 用来标记
				break;
				// cout << "Wrong" << endl; // 或者直接输出Wrong后return 0;
				// return 0;
			}
			c = s[tmp-1];
			if (c == '[') {
				tmp --;
			}
			else {
				cnt = 0; // 用来标记
				break;
				// cout << "Wrong" << endl; // 或者直接输出Wrong后return 0;
				// return 0;
			}
		}
	}
	if (tmp == 0 && cnt != 0) {
		cout << "OK" << endl;
	}
	else {
		cout << "Wrong" << endl;
	}
	return 0;
}

 

上一篇:一本通1354 括弧匹配检验


下一篇:P6823 「EZEC-4」zrmpaul Loves Array