汉诺塔
Problem Description
汉诺塔(又称河内塔)问题是印度的一个古老的传说。
开天辟地的神勃拉玛在一个庙里留下了三根金刚石的棒A、B和C,A上面套着n个圆的金片,最大的一个在底下,其余一个比一个小,依次叠上去,庙里的众僧不倦地把它们一个个地从A棒搬到C棒上,规定可利用中间的一根B棒作为帮助,但每次只能搬一个,而且大的不能放在小的上面。
僧侣们搬得汗流满面,可惜当n很大时这辈子恐怕就很搬完了。
聪明的你还有计算机帮你完成,你能写一个程序帮助僧侣们完成这辈子的夙愿吗?
Input
输入金片的个数n。这里的n<=10。
Output
输出搬动金片的全过程。格式见样例。
Sample Input
2
Sample Output
Move disk 1 from A to B
Move disk 2 from A to C
Move disk 1 from B to C
Hint
可以用递归算法实现。
Source
注:提交时WA多次,最后删除 package test才能AC,至于为啥,目前还不知道package test
import java.util.Scanner;
import java.lang.Math;
public class Main {
public static void hanoi(int n, char a, char b, char c) {
if (n == 1) {
System.out.printf("Move disk %d from %c to %c\n", n, a, c); // 递归出口,将最后一个圆盘从A移动到C
return;
}
else {
hanoi(n-1, a, c, b); // 将1到n-1号圆盘从A移动到B
System.out.printf("Move disk %d from %c to %c\n",n, a, c);
// 把第n号圆盘从A移至C
hanoi(n-1, b, a, c); // 将1号到n-1号圆盘从B移到C
}
}
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
hanoi(n, 'A', 'B', 'C');
}
}