【团体程序设计天梯赛-练习集】L1-025--正整数A+B

题的目标很简单,就是求两个正整数A和B的和,其中A和B都在区间[1,1000]。稍微有点麻烦的是,输入并不保证是两个正整数。

输入格式:

输入在一行给出A和B,其间以空格分开。问题是A和B不一定是满足要求的正整数,有时候可能是超出范围的数字、负数、带小数点的实数、甚至是一堆乱码。

注意:我们把输入中出现的第1个空格认为是A和B的分隔。题目保证至少存在一个空格,并且B不是一个空字符串。

输出格式:

如果输入的确是两个正整数,则按格式A + B = 和输出。如果某个输入不合要求,则在相应位置输出?,显然此时和也是?。
输入样例1:

123 456

输出样例1:

123 + 456 = 579

输入样例2:

22. 18

输出样例2:

? + 18 = ?

输入样例3:

-100 blabla bla...33

输出样例3:

? + ? = ?


代码

#include <iostream>
#include <string>
#include <cstdlib>
using namespace std;

int main(){
    bool aj, bj;
    int v1, v2, v3;
    string a, b;
    string::iterator it;
    aj = bj = 0;
    getline(cin, a, ' ');
    getline(cin, b);
    for(it = a.begin(); it != a.end(); ++it){
        if(*it < '0' || *it > '9' || (*it == '0' && it == a.begin())){
            aj = 1;
            break;
        }
    }
    for(it = b.begin(); it != b.end(); ++it){
        if(*it < '0' || *it > '9' || (*it == '0' && it == b.begin())){
            bj = 1;
            break;
        }
    }
    if(!aj){
        v1 = atoi(a.c_str());
        if(v1 > 1000) aj++;
    }
    if(!bj){
        v2 = atoi(b.c_str());
        if(v2 > 1000) bj++;
    }
    if(!aj) cout << a << ' ' << '+' << ' ';
    else cout << '?' << ' ' << '+' << ' ';
    if(!bj) cout << b << ' ' << '=' << ' ';
    else cout << '?' << ' ' << '=' << ' ';
    if(!aj && !bj){
        v3 = v1 + v2;
        cout << v3 << endl;
    }
    else cout << '?' << endl;
    return 0;
}
上一篇:Node.js躬行记(12)——BFF


下一篇:[Linux] 025 yum 命令