POJ3904 Sky Code

题意

Language:Default
Sky Code
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3980 Accepted: 1333

Description

Stancu likes space travels but he is a poor software developer and will never be able to buy his own spacecraft. That is why he is preparing to steal the spacecraft of Petru. There is only one problem – Petru has locked the spacecraft with a sophisticated cryptosystem based on the ID numbers of the stars from the Milky Way Galaxy. For breaking the system Stancu has to check each subset of four stars such that the only common divisor of their numbers is 1. Nasty, isn’t it? Fortunately, Stancu has succeeded to limit the number of the interesting stars to N but, any way, the possible subsets of four stars can be too many. Help him to find their number and to decide if there is a chance to break the system.

Input

In the input file several test cases are given. For each test case on the first line the number N of interesting stars is given (1 ≤ N ≤ 10000). The second line of the test case contains the list of ID numbers of the interesting stars, separated by spaces. Each ID is a positive integer which is no greater than 10000. The input data terminate with the end of file.

Output

For each test case the program should print one line with the number of subsets with the asked property.

Sample Input

4
2 3 4 5
4
2 4 6 8
7
2 3 4 5 7 6 8

Sample Output

1
0
34

Source

给你N个整数,从这N个数中选择4个数,使得这四个数的公约数为1。求满足条件的四元组个数。

分析

参照lianai911的题解。

四个数的公约数为1,并不代表四个数两两互质。比如(2,3,4,5)公约数为1,但是2和4并不互质。从反面考虑,先求出四个数公约数不为1的情况个数,用总的方案个数减去四个数公约数不为1的情况个数就是所求。

求四个数公约数不为1的情况个数,需要将N个数每个数质因数分解,纪录下所有不同的素因子所能组成的因子(就是4个数的公约数),并统计构成每种因子的素因子个数,和因子总数。然后再计算组合数。比如说因子2的个数为a,则四个数公约数为2的个数为C(a,4),因子3的个数为b,则四个数公约数为3的个数为C(b,4),因子6(2*3)的个数为c,则四个数公约数的个数为C(c,4)。

但是公约数为2的情况中或者公约数为3的情况中可能包括公约数为6的情况,相当于几个集合求并集,这就需要容斥定理来做。以公约数中质因子个数的奇偶区分加减。

时间复杂度\(O(n\sqrt{n})\)

代码

#include<iostream>
#include<cstring>
#define rg register
#define il inline
#define co const
template<class T>il T read(){
rg T data=0,w=1;rg char ch=getchar();
while(!isdigit(ch)) {if(ch=='-') w=-1;ch=getchar();}
while(isdigit(ch)) data=data*10+ch-'0',ch=getchar();
return data*w;
}
template<class T>il T read(rg T&x) {return x=read<T>();}
typedef long long ll; co int N=1e4+1;
ll x[N];
int n,a[N],cnt[N],p[N],tot;
void work(int n){
tot=0;
for(int i=2;i*i<=n;++i)if(n%i==0){
p[tot++]=i;
while(n%i==0) n/=i;
}
if(n>1) p[tot++]=n;
for(int i=1,t,num;i<1<<tot;++i){
t=1,num=0;
for(int j=0;j<tot;++j)
if(i>>j&1) t*=p[j],++num;
++cnt[t],a[t]=num;
}
}
int main(){
// freopen(".in","r",stdin),freopen(".out","w",stdout);
for(int i=4;i<N;++i)
x[i]=(ll)i*(i-1)*(i-2)*(i-3)/24;
while(~scanf("%d",&n)){
memset(cnt,0,sizeof cnt);
for(int i=1;i<=n;++i) work(read<int>());
ll ans=0;
for(int i=2;i<N;++i)if(cnt[i]>3)
a[i]&1?ans+=x[cnt[i]]:ans-=x[cnt[i]];
printf("%lld\n",x[n]-ans);
}
return 0;
}
上一篇:springboot打成Jar包后部署至Linux服务器上


下一篇:JAVA虚拟机:对象的创建过程