NYOJ_37.回文字符串 (附滚动数组)

时间限制:3000 ms  |  内存限制:65535 KB
难度:4
描述
所谓回文字符串,就是一个字符串,从左到右读和从右到左读是完全一样的,比如"aba"。当然,我们给你的问题不会再简单到判断一个字符串是不是回文字符串。现在要求你,给你一个字符串,可在任意位置添加字符,最少再添加几个字符,可以使这个字符串成为回文字符串。
输入
第一行给出整数N(0<N<100)

接下来的N行,每行一个字符串,每个字符串长度不超过1000.
输出
每行输出所需添加的最少字符数
样例输入
1
Ab3bd
样例输出
2
来源
IOI 2000
上传者
hzyqazasdf
 #include <iostream>
 #include <stdlib.h>
 #include <stdio.h>
 #include <string>
 #include <string.h>
 #include <algorithm>//reverse
 #include <vector>
 using namespace std;
 #define debug(x) cout << #x << " at line " << __LINE__ << " is: " << x << endl
 ][];

 int dphwzfc(char *bufings, int n);
 int main(){
     int N;
     scanf("%d", &N);
     getchar();
     while (N--) {
         ] = {};
         ] = {};
         ;
         scanf("%s", buf);
         getchar();
         memset(dpth, 0x00, sizeof(dpth));
         int buflen = strlen(buf);
          || buflen == ){
             printf("%d\n", result);
             continue;
         }
         //int lcslen = 0;
         ;
         ;
         ) {
             s[sidx++] = buf[idx--];
         }
         //cout << sidx << endl;
         s[sidx] = '\0';
 //        for (int i = 0; i < buflen; ++i) {
 //            if(s[0] == buf[i]){
 //                dpth[0][i] = 1;
 //            }else {
 //                dpth[0][i] = 0;
 //            }
 //            if(s[i] == buf[0]){
 //                dpth[i][0] = 1;
 //            }else {
 //                dpth[i][0] = 0;
 //            }
 //        }

         ; i < buflen; ++i) {
             ; j < buflen; ++j) {
                 if(s[i] == buf[j]){
                     dpth[i+][j+] = dpth[i][j]+;
                 }else{
                     dpth[i+][j+] = max(dpth[i+][j], dpth[i][j+]);
                 }

 //                if(dpth[i][j] > lcslen){
 //                    lcslen = dpth[i][j];
 //                }

             }
         }
 //cout << dpth[buflen-1][buflen-1] << endl;
         result = buflen - dpth[buflen][buflen];
         printf("%d\n", result);
     }
     ;
 }

滚动数组

滚动数组的作用在于优化空间,主要应用在递推或动态规划中(如01背包问题)。

滚动数组实际是一种节省空间的办法,时间上没啥优势,多用于DP中

上一篇:Hibernate包及相关工具包下载地址


下一篇:【HIHOCODER 1323】回文字符串(区间DP)