输入一个字符串和一个非负整数N,要求将字符串循环左移N次。
输入格式:
输入在第1行中给出一个不超过100个字符长度的、以回车结束的非空字符串;第2行给出非负整数N。
输出格式:
在一行中输出循环左移N次后的字符串。
输入样例:
Hello World!
2
输出样例:
llo World!He
#include<stdio.h>
#include<string.h>
void reverse(char a[],int n)
{
int i;
char temp;
for(i=0;i<n/2;i++)
{
temp=a[i];
a[i]=a[n-i-1];
a[n-i-1]=temp;
}
}
int main()
{
char a[103];
gets(a);
int str=strlen(a);
int n;
scanf("%d",&n);
n=n%str;
reverse(a,n);
reverse(a+n,str-n);
reverse(a,str);
printf("%s\n",a);
return 0;
}