Semi-prime H-numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8069 Accepted: 3479
Description
This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.
An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,… are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.
As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.
For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.
Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it’s the product of three H-primes.
Input
Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.
Output
For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.
Sample Input
21
85
789
0
Sample Output
21 0
85 5
789 62
Source
Waterloo Local Contest, 2006.9.30
类似素数筛
#include <set>
#include <map>
#include <list>
#include <stack>
#include <cmath>
#include <queue>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#define PI cos(-1.0)
#define RR freopen("input.txt","r",stdin)
using namespace std;
typedef long long LL;
const int MAX = 1e6+100;
int vis[MAX];
int Dp[MAX];
int main()
{
memset(vis,0,sizeof(vis));
for(LL i=5;i<MAX;i+=4)//标记Semi-prime H-numbers
{
for(LL j=i;j<MAX;j+=4)
{
LL ans=i*j;
if(ans>MAX)
{
break;
}
if(vis[i]==0&&vis[j]==0)
{
vis[ans]=1;
}
else
{
vis[ans]=-1;
}
}
}
Dp[0]=0;
for(int i=1;i<MAX;i++)//记录从1-i之间的Semi-prime H-numbers个数
{
if(vis[i]==1)
{
Dp[i]=Dp[i-1]+1;
}
else
{
Dp[i]=Dp[i-1];
}
}
int n;
while(scanf("%d",&n)&&n)
{
printf("%d %d\n",n,Dp[n]);
}
return 0;
}