Find The Multiple
https://vjudge.net/problem/POJ-1426
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
C++
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n;
int dfs(long long ans, int step)
{
if(step > 19){
return 0;
}
if(ans % n == 0){
printf("%lld\n", ans);
return 1;
}
if(dfs(ans * 10, step + 1))
return 1;
if(dfs(ans * 10 + 1, step + 1))
return 1;
return 0;
}
int main()
{
while(scanf("%d", &n) != EOF)
{
if(n == 0) break;
dfs(1, 1);
}
return 0;
}
剑气扬名
发布了12 篇原创文章 · 获赞 0 · 访问量 987
私信
关注