如果图中存在有向环,则不存在拓扑排序,反之则存在。不包含有向环的有向图成为有向无环图。可借助DFS完成拓扑排序:在访问完一个结点之后把它加到当前拓扑排序的首部。
int c[maxn];
int topo[maxn],t;
bool dfs(int u){
c[u]=-1;//访问标志
for(int v=0;v<n;v++){
if(G[u][v]){
if(c[v]<0) return false;//存在有向环,失败退出
else if(!c[v]&&!dfs(v)) return false;
}
}
c[u]=1;
topo[--t]=u;
return true;
}
bool toposort(){
t=n;
memset(c,0,sizeof(c));
for(int u=0;u<n;u++){
if(!c[u]){
if(!dfs(u)) return false;
}
}
return true;
}
c[u]=0表示从来没有访问过(从来没有调用过dfs(u));c[u]=1表示已经访问过,并且还递归访问过它的所有子孙(即dfs(u)曾被调用过,并已返回);c[u]=-1表示正在访问(即递归调用dfs(u)正在帧栈中,尚未返回)。
1146 Topological Order (25 分)
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4//不是拓扑排序的序号
题目大意:给一个有向图,判断给定序列列是否是拓扑序列~
分析:用邻接表v存储这个有向图,并将每个节点的入度保存在in_degree数组中。对每一个要判断是否是拓扑序列的结点遍历,如果当前结点的入度不为0则表示不是拓扑序列,每次选中某个点后要将它所指向的所有结点的入度-1,最后根据是否出现过入度不为0的点决定是否要输出当前的编号i~flag是用来判断之前是否输出过现在是否要输出空格的~judge是用来判断是否是拓扑序列的~
#include <iostream>
#include <vector>
using namespace std;
const int N = 1010;
int main(){
//freopen("1.txt","r",stdin);
int n,m,x,y,k;
int in_degree[N]={0},flag=0;
scanf("%d%d",&n,&m);
vector<int>v[n+1];
while(m--){
scanf("%d%d",&x,&y);
v[x].push_back(y);
in_degree[y]++;
}
scanf("%d",&k);
for(int i=0;i<k;i++){
int judge=1;
vector<int>back_up(in_degree,in_degree+n+1);
for(int j=0;j<n;j++){
scanf("%d",&x);
if(back_up[x]!=0) judge=0;
for(auto y:v[x]) back_up[y]--;
}
if(judge==1) continue;
printf("%s%d",flag==1?" ":"",i);
flag=1;
}
return 0;
}