Strange fuction |
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) |
Total Submission(s): 661 Accepted Submission(s): 544 |
Problem Description
Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100) Can you find the minimum value when x is between 0 and 100. |
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
|
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
|
Sample Input
2 |
Sample Output
-74.4291 |
Author
Redow
|
Recommend
lcy
|
/*
拐了点小弯,最小值点就是导数为零的点
*/
#include<bits/stdc++.h>
#define op 1e-8
using namespace std;
double F(double x,double y)
{
return *x*x*x*x*x*x*x+*x*x*x*x*x*x+*x*x*x+*x*x-y*x;
}
double derivative_F(double x,double y)
{
return *x*x*x*x*x*x+*x*x*x*x*x+*x*x+*x-y;
}
int main()
{
//freopen("C:\\Users\\acer\\Desktop\\in.txt","r",stdin);
int t;
double y;
scanf("%d",&t);
while(t--)
{
scanf("%lf",&y);
double l=,r=,mid;
while(fabs(r-l)>op)
{
mid=(r+l)*1.0/;
if(derivative_F(mid,y)>)
r=mid;
else
l=mid;
}
printf("%.4lf\n",F(l,y));
}
return ;
}