PAT甲级真题 1012 The Best Rank (25分) C++实现(vector排序后,map记录)

题目

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C, M, E and A - Average of 4 students are given as the following:
StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.
Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output N/A.
Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A

思路

难点在于想清楚存储信息的数据结构。

为A、C、M、E四种成绩分别建立1个结构体数组,和1个排名榜单(用unordered_map记录,以id为key,以排名为value);对每门课程成绩排序,将排序结果记录到unordered_map中(unordered_map也可替换为vector以提高时间效率)。对每个查询的学生id,在A、C、M、E四个排名榜单中查找出其第一个最小排名及对应课程号即可。

需要注意以下两点:

  1. 由题目给的样例可知,平均成绩是四舍五入取得的;
  2. 测试点2考察的是,当两个学生成绩相同时,排名也应当相同。假设有并列第一,那么排名应该是1,1,3,4……

代码

#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>
using namespace std;

struct Info{
    int id;
    int grade;
};

bool cmp(Info i1, Info i2){
    return i1.grade > i2.grade;
}
int main(){
    int n, m;
    cin >> n >> m;
    vector<vector<Info> > g(4, vector<Info>(n)); //四个数组分别存储a, c, m, e
    for (int i=0; i<n; i++){
        int id;
        cin >> id;
        int sum = 0;
        for (int j=1; j<4; j++){
            cin >> g[j][i].grade;
            sum += g[j][i].grade;
            g[j][i].id = id;
        }
        g[0][i].grade = sum / 3 + 0.5; //四舍五入
        g[0][i].id = id;
    }
    vector<unordered_map<int, int> > rank(4);
    for (int i=0; i<4; i++){
        sort(g[i].begin(), g[i].end(), cmp);
        int lastGrade = 101;
        int lastRank = 0;
        for (int j=0; j<n; j++){
            int id = g[i][j].id;
            if (g[i][j].grade == lastGrade){
                rank[i][id] = lastRank;
            }
            else{
                rank[i][id] = j + 1;
                lastGrade = g[i][j].grade;
                lastRank = j + 1;
            }
        }
    }
    char course[] = {'A', 'C', 'M', 'E'};
    for (int i=0; i<m; i++){
        int id; 
        cin >> id;
        if (rank[0].find(id)==rank[0].end()){
            cout << "N/A" << endl;
        }
        else {
            int best = n + 1;
            int bestCourse = -1;
            for (int j=0; j<4; j++){
                if (rank[j][id] < best){
                    best = rank[j][id];
                    bestCourse = j;
                }
            }
            cout << best << " " << course[bestCourse] << endl;
        }
    }
    return 0;
}
PAT甲级真题 1012 The Best Rank (25分) C++实现(vector排序后,map记录)PAT甲级真题 1012 The Best Rank (25分) C++实现(vector排序后,map记录) zhang35 发布了142 篇原创文章 · 获赞 7 · 访问量 3532 私信 关注
上一篇:javascript内置对象之一Math


下一篇:《编写高质量代码 改善python程序的91个建议》1-5