算法:深搜(水题);
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
代码:
#include <iostream>
#include <cstring>
#include <iomanip>
#include <stdio.h>
using namespace std;
int p;
void dfs(unsigned __int64 t,int n,int k)
{
if(p) return;
if(t%n==0)
{
cout<<t<<endl;
p=1;
return;
}
if(k==19) return;
dfs(t*10+1,n,k+1);
dfs(t*10,n,k+1); }
int main()
{
int n,m,k;
while(cin>>n&&n)
{
p=0;
k=1;
dfs(1,n,k);
}
}