Borg Maze
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 8905 | Accepted: 2969 |
Description
Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.
Input
Output
Sample Input
2
6 5
#####
#A#A##
# # A#
#S ##
#####
7 7
#####
#AAA###
# A#
# S ###
# #
#AAA###
#####
Sample Output
8
11 思路:bfs得外星人间最小距离(假设人类是第0号外星人),prim得最小生成树
#include<cstdio>
#include <cstring>
#include <queue>
#include <assert.h>
using namespace std;
char maz[202][202];
bool vis[202][202];
int d[201][202][202];
int alien[201][2];
int numa;
int x,y;
int sx,sy;
int e[202][202];
typedef pair<int,int> P;
queue<P> que;
const int dx[4]={0,0,-1,1};
const int dy[4]={-1,1,0,0};
bool used[101];
void bfs(){
sx=sy=-1;//处理迷宫
numa=0;
memset(vis,0,sizeof(vis));
for(int i=0;i<y;i++){
for(int j=0;j<x;j++){
if(maz[i][j]=='S'){
sx=j;
sy=i;
break;
}
}
}
assert(sx!=-1&&sy!=-1);
vis[sy][sx]=true;
d[0][sy][sx]=0;
alien[numa][0]=sy;
alien[numa++][1]=sx;
que.push(P(sy,sx));
while(!que.empty()){//从人类出发bfs
P p=que.front();
que.pop();
for(int i=0;i<4;i++){
int ny=p.first+dy[i];
int nx=p.second+dx[i];
if(nx>=0&&nx<x&&ny>=0&&ny<y&&!vis[ny][nx]&&maz[ny][nx]!='#'){
d[0][ny][nx]=d[0][p.first][p.second]+1;
vis[ny][nx]=true;
que.push(P(ny,nx));
if(maz[ny][nx]=='A'){
alien[numa][0]=ny;
alien[numa++][1]=nx;
}
}
}
}
for(int ai=1;ai<numa;ai++){//从每个外星人出发bfs
memset(vis,0,sizeof(vis));
int ay=alien[ai][0],ax=alien[ai][1];
d[ai][ay][ax]=0;
que.push(P(ay,ax));
vis[ay][ax]=true;
while(!que.empty()){
P p=que.front();
que.pop();
for(int i=0;i<4;i++){
int ny=p.first+dy[i];
int nx=p.second+dx[i];
if(nx>=0&&nx<x&&ny>=0&&ny<y&&!vis[ny][nx]&&maz[ny][nx]!='#'){
d[ai][ny][nx]=d[ai][p.first][p.second]+1;
vis[ny][nx]=true;
que.push(P(ny,nx));
}
}
}
}
for(int i=0;i<numa;i++){//建图
//int ay=alien[i][0],ax=alien[i][1];
for(int j=0;j<numa;j++){
int ay1=alien[j][0],ax1=alien[j][1];
e[i][j]=d[i][ay1][ax1];
}
}
}
priority_queue <P,vector<P>, greater <P> > pque;
int prim(){
memset(used,0,sizeof(used));
used[0]=true;
int unum=1;
for(int i=1;i<numa;i++){
pque.push(P(e[0][i],i));
}
int ans=0;
while(unum<numa){
int t=pque.top().second;
int td=pque.top().first;
pque.pop();
if(used[t])continue;
ans+=td;
used[t]=true;
unum++;
for(int i=0;i<numa;i++){
if(!used[i]){
pque.push(P(e[t][i],i));
}
}
}
while(!pque.empty())pque.pop();
return ans;
}
int main(){
int t;
scanf("%d",&t);
while(t--){
scanf("%d%d",&x,&y);
gets(maz[0]);//抛弃空行
for(int i=0;i<y;i++){
gets(maz[i]);
}
bfs();
int ans=prim();
printf("%d\n",ans);
}
}