Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.
A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
Output
For each input m n, if safe holes exist, you should output “YES”, else output “NO” in a single line.
Sample Input
2
1 2
2 2
Sample Output
NO
YES
Author
weigang Lee
Source
杭州电子科技大学第三届程序设计大赛
Recommend
Ignatius.L
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cmath>
#include <cstdio>
using namespace std;
#define ll long long
ll gcd(ll a, ll b)
{
return b==0?a:gcd(b,a%b);
} //模板
int main()
{
int p;
scanf("%d",&p);
while(p--){
ll m, n;
scanf("%lld%lld",&m,&n);
if(gcd(m,n)==1)
printf("NO\n");
else
printf("YES\n");
}
return 0;
}
Flying_fish101
发布了20 篇原创文章 · 获赞 0 · 访问量 1028
私信
关注