POJ 题目3661 Running(区间DP)

Running
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5652   Accepted: 2128

Description

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her 'exhaustion factor', which starts at 0. When she chooses to run in minute i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion factor will increase by 1 -- but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches 0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie's exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M
* Lines
2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run
while satisfying the conditions.
 

Sample Input

5 2
5
3
4
2
10

Sample Output

9

Source

题意:给你n,m,后边n个数,一个人第i分钟可以移动a[i]长度,每分钟会多1点疲劳,疲劳值不能超过m,到m必须休息,每个时间点都可以休息,每次休息就必须休息到疲劳值为0,问时间消耗m分钟后,疲劳为0走的最大长度
ac代码
#include<stdio.h>
#include<string.h>
#define min(a,b) (a>b?a:b)
int dp[10010][505],a[10010];
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
int i,j,k;
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
{
dp[i][j]=dp[i-1][j-1]+a[i];
}
dp[i][0]=dp[i-1][0];
for(k=1;k<=m;k++)
{
if(i-k>=0)
dp[i][0]=min(dp[i][0],dp[i-k][k]);
}
}
printf("%d\n",dp[n][0]);
}
}

  

上一篇:poj 1915 http://poj.org/problem?id=1915


下一篇:HDU 1281 棋盘游戏 【二分图最大匹配】