VJ基础练习题三
J - 最小长方形
给定一系列2维平面点的坐标(x, y),其中x和y均为整数,要求用一个最小的长方形框将所有点框在内。长方形框的边分别平行于x和y坐标轴,点落在边上也算是被框在内。
Input
测试输入包含若干测试用例,每个测试用例由一系列坐标组成,每对坐标占一行,其中|x|和|y|小于 231;一对0 坐标标志着一个测试用例的结束。注意(0, 0)不作为任何一个测试用例里面的点。一个没有点的测试用例标志着整个输入的结束。
Output
对每个测试用例,在1行内输出2对整数,其间用一个空格隔开。第1对整数是长方形框左下角的坐标,第2对整数是长方形框右上角的坐标。
Sample Input
12 56
23 56
13 10
0 0
12 34
0 0
0 0
Sample Output
12 10 23 56
12 34 12 34
Wrong Answer
#include<iostream>
#include<string>
#include <algorithm>
#include <vector>
#include <cmath>
using namespace std;
int main()
{
while(cin.peek()){
int x_t,y_t;
vector<int>x,y;
while(cin>>x_t>>y_t){
if(x_t==0&&y_t==0){
break;
}
x.push_back(x_t);
y.push_back(y_t);
}
sort(x.begin(),x.end());
sort(y.begin(),y.end());
cout<<x.at(0)<<" "<<y.at(0)<<" "<<x.at(x.size()-1)<<" "<<y.at(y.size()-1)<<endl;
}
return 0;
}
Time Limit Exceeded
#include<iostream>
#include<string>
using namespace std;
int main()
{
while(cin.peek()){
int x_t,y_t;
int xmin,ymin,xmax,ymax;
xmin=ymin=233;
xmax=ymax=-233;
// vector<int>x,y;
int n = 0;
while(cin>>x_t>>y_t){
if(x_t==0&&y_t==0){
break;
}
n++;
xmin=min(xmin,x_t);
ymin=min(ymin,y_t);
xmax=max(xmax,x_t);
ymax=max(ymax,y_t);
}
if(n!=0){
cout<<xmin<<" "<<ymin<<" "<<xmax<<" "<<ymax<<"\n";
}
}
return 0;
}
Accepted
#include<iostream>
#include<string>
using namespace std;
main()
{
while(cin.peek()){
int x_t,y_t;
int xmin,ymin,xmax,ymax;
xmin=ymin=233;
xmax=ymax=-233;
// vector<int>x,y;
int n = 0;
while(cin>>x_t>>y_t){
if(x_t==0&&y_t==0){
break;
}
n++;
xmin=min(xmin,x_t);
ymin=min(ymin,y_t);
xmax=max(xmax,x_t);
ymax=max(ymax,y_t);
}
if(n==0){
break;
}
cout<<xmin<<" "<<ymin<<" "<<xmax<<" "<<ymax<<"\n";
}
return 0;
}
RY_zeze
发布了17 篇原创文章 · 获赞 0 · 访问量 39
私信
关注