1051 Pop Sequence(stl,栈的运用)

1051 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

/**
本题题意
    就是 输入 m , n, k 分别表示一个栈中能装入的最大容量,n 表示 入栈的顺序为 1 - n, k表示 一共有k
个序列此时需要判断 k个序列 通过 1 - n 的入栈顺序能否实现.
本题思路:
    设定一个b数组存放规定的序列, 设定一个下标j 指向b数组的首元素,比较b[j] 和  s.top()(栈顶元素)
    是否相等, 相等就 s.pop(), b[j++].
    最后判断栈中元素为空那么此序列就正确, 就可以输出yes;
**/

值得注意的是 :如果栈中元素为空, s.top() 会出现错误。 因此要作空判断.

#include<iostream>
#include<stack>
using namespace std;
int n, m, k, num, b[1005];
int main(){
	stack<int> s;
	scanf("%d%d%d", &m, &n, &k);;
	while(k--){
		int j = 0;
		while(!s.empty())
			s.pop();
		for(int i = 0; i < n; i++){
			scanf("%d", &num);
			b[i] = num;	
		}
		for(int i = 1; i <= n; i++){
			s.push(i);
			if(s.size() > m)
				break;
			while(!s.empty() && s.top() == b[j]){ //s.empty() 是必须加上判断的 
				s.pop();
				j++;
			}	
		}
		if(!s.empty())
			printf("NO\n");
		else
			printf("YES\n"); 	
	}
	return 0;
}

 

上一篇:PTA乙级1051


下一篇:1051 复数乘法(C语言)