Expanding Rods(二分+计算几何)

Description

Expanding Rods(二分+计算几何)When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000

                          解析传送门

     相交弦定理,高中接触过,二分枚举高度和弦长比较

  

#include<iostream>
#include<cmath>
#include<iomanip>
#include<cstdio>
using namespace std;
int main()
{
  // freopen("input.txt","r",stdin);
    double l,n,c;
    while(cin>>l>>n>>c&&l>=0)
    {
        double L=(1+n*c)*l;
        double left=0,right=l/2;
        double mid,r;
        while(right-left>1e-6)
        {
           mid=(left+right)/2;
           r=l*l/8/mid+mid/2;
           if(r*2*(asin(l/2/r))<L)
           {
               left=mid;
           }
           else right=mid;
        }
        cout<<fixed<<setprecision(3)<<mid<<endl;
    }
}

 

上一篇:# Expanding Rods//POJ - 1905//二分


下一篇:The history of spring and design concept