Description
求一个给定的圆(x^2+y^2=r^2),在圆周上有多少个点的坐标是整数。
Input
只有一个正整数n,n<=2000 000 000
Output
整点个数
Sample Input
4
Sample Output
4
HINT
Source
Solution
#include <bits/stdc++.h>
using namespace std;
typedef long long ll; ll gcd(ll a, ll b)
{
return b ? gcd(b, a % b) : a;
} int main()
{
ll r, d, a, ans = ;
double b;
cin >> r;
for(d = (ll)(sqrt(2.0 * r) + 0.5); d; --d)
{
if( * r % d) continue;
for(a = (ll)(sqrt(1.0 * r / d) + 1e-); a; --a)
{
b = sqrt(2.0 * r / d - a * a);
if(b - (ll)b > 1e-) continue;
if(a != (ll)b && gcd(a, (ll)b) == ) ++ans;
}
if(d == * r / d) continue;
for(a = (ll)(sqrt(0.5 * d) + 1e-); a; --a)
{
b = sqrt(d - a * a);
if(b - (ll)b > 1e-) continue;
if(a != (ll)b && gcd(a, (ll)b) == ) ++ans;
}
}
cout << ans * << endl;
return ;
}