C语言2.0

Problem Description Your task is to Calculate a + b.
Input Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.

Output For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input1 5
10 20
0 0

Sample Output6
30

#include<stdio.h>
int main()
{
 int a,b,n,i;
 while((a!=0&&b!=0)||(a==0&&b!=0)||(a!=0&&b==0))
 {
     scanf("%d %d",&a,&b);
     if(a==0&&b==0)
       return 0;
     printf("%d\n",a+b); 
 }
 
 } 

Problem Description Your task is to Calculate the sum of some integers.

Input Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

Output For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input4 1 2 3 4
5 1 2 3 4 5
0

Sample Output10
15

#include<stdio.h>
int main()
{
 int n=1,a[9]={0},i,b[9],j,s=0;
 while(n!=0){
     s=0;
  scanf("%d",&n);
  if(n==0)
   return 0;
  for(i=1;i<=n;i++)
    {
     scanf("%d",&a[i]);
    s=s+a[i];
    }
    printf("%d\n",s);
 }
 
}
上一篇:D - Three Integers


下一篇:Codeforces Round #626(Count Subrectangles)