1037 Magic Coupon (25 分)
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!
For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1≤NC,NP≤105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
代码如下:
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
bool compare(int a,int b)
{
return a > b;
}
int main()
{
int M, N;
cin >> M;
vector<int> coupon, product;
for (int i = 0; i < M; i++)
{
int temp;
cin >> temp;
coupon.push_back(temp);
}
cin >> N;
for (int i = 0; i < N; i++)
{
int temp;
cin >> temp;
product.push_back(temp);
}
sort(coupon.begin(), coupon.end(), compare);
sort(product.begin(), product.end(), compare);
int positiveCouponCount = 0, positiveProductCount = 0;;
for (int i = 0; i < M; i++)
{
if (coupon[i] > 0)
{
positiveCouponCount++; //正数券数量
}
else
{
break;
}
}
for (int i = 0; i < N; i++)
{
if (product[i] > 0)
{
positiveProductCount++; //正数产品数量
}
else
{
break;
}
}
int size;
int index;
if (M > N)
{
size = N;
index = positiveProductCount;
}
else if (M < N)
{
size = M;
index = positiveCouponCount;
}
else if (M == N)
{
size = M;
index = positiveCouponCount;
}
int count = 0;
for (int i = 0; i < index; i++)
{
if (coupon[i] * product[i] > 0)
{
count += coupon[i] * product[i];
}
}
for (int i =0; i<size-index; i++)
{
if (coupon[M - i - 1] * product[N - i - 1] > 0)
{
count += coupon[M - i - 1] * product[N-i-1];
}
}
cout<<count;
system("pause");
return 0;
}