poj 1579(动态规划初探之记忆化搜索)

Function Run Fun
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17843   Accepted: 9112

Description

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:

1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:

w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:

w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:

w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if
implemented directly, for moderate values of a, b and c (for example, a =
15, b = 15, c = 15), the program takes hours to run because of the
massive recursion.

Input

The
input for your program will be a series of integer triples, one per
line, until the end-of-file flag of -1 -1 -1. Using the above technique,
you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

记忆化搜索。照着思路走。不过把已经搜索过的就不要重复计算了
#include<iostream>
#include<cstdio>
#include<algorithm>
#include <string.h>
#include <math.h>
using namespace std; int f[][][];
int dfs(int a,int b,int c){
if(a<=||b<=||c<=) return ;
if(a>||b>||c>) return dfs(,,);
if(f[a][b][c]!=-) return f[a][b][c];
if(a<b&&b<c) f[a][b][c] = dfs(a,b,c-)+dfs(a,b-,c-)-
dfs(a,b-,c);
else f[a][b][c]= dfs(a-,b,c)+dfs(a-,b-,c)+dfs(a-,b,c-)
-dfs(a-,b-,c-);
return f[a][b][c];
}
int main()
{
int a,b,c;
while(scanf("%d%d%d",&a,&b,&c)!=EOF){
if(a==-&&b==-&&c==-) break;
memset(f,-,sizeof(f));
int ans = dfs(a,b,c);
printf("w(%d, %d, %d) = %d\n",a,b,c,ans);
}
return ;
}
上一篇:poj 1088 动态规划+dfs(记忆化搜索)


下一篇:Linux 链接详解(1)