HDOJ1312 Red and black(DFS深度优先搜索)

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).


Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0


Sample Output

45
59
6
13

#include<stdio.h>
#include<string.h>
using namespace std;
char s[50][50];
int n,m;
int dfs(int x,int y)
{
    int i,j,k;
    if(x<0||x>n-1||y<0||y>m-1)
        return 0;
    
    if(s[x][y]=='#')
    {
        return 0;
    }    
    else
    {
        s[x][y]='#';
        return 1+dfs(x+1,y)+dfs(x-1,y)+dfs(x,y+1)+dfs(x,y-1);//搜索四个方向
    }
}
int main() 
{
    int i,j,k;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        if(m==0&&n==0)
            break;
        for(i=0;i<n;i++)
        {
            scanf("%s",s[i]);
        }
        int sum=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(s[i][j]=='@')
                {
                    sum=dfs(i,j);    
                } 
            } 
        }
        printf("%d\n",sum);
    }
    return 0;
}

永不言弃!和ACM死磕到底!

上一篇:2020 CCPC Wannafly Winter Camp Day2-K-破忒头的匿名信


下一篇:决策树- 随机森林/GBDT/XGBoost