Red and Black

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

 

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

 

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

 

 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题意: 求和@相连的黑瓷砖(.和@)的个数

#include<stdio.h>
#include<string.h>
#include<math.h>
char map[21][21];
int gx,gy,wall;
int n,m;
int dx[4]={0,-1,0,1};
int dy[4]={1,0,-1,0};
int a[21][21];
int sum;
void dfs(int sx,int sy){
    int i;
    if(sx<0||sy<0||sx>=n||sy>=m)return ;
    for(i=0;i<4;i++){
        if(map[sx+dx[i]][sy+dy[i]]=='.'&&a[sx+dx[i]][sy+dy[i]]==0){
            sum++;
            a[sx+dx[i]][sy+dy[i]]=1;
            dfs(sx+dx[i],sy+dy[i]);
        }
    }
    return ;
}
int main(){
    
    int i,j,sx,sy;
    while(~scanf("%d %d%*c",&m,&n)){
        if(m==0&&n==0){
            break;
        }
        memset(map,0,sizeof(map));
        memset(a,0,sizeof(a));
        for(i=0;i<n;i++){
            for(j=0;j<m;j++){
                scanf("%c",&map[i][j]);
                if(map[i][j]=='@'){
                    sx=i;
                    sy=j;
                }
            }
            getchar();
        }
        sum=1;
        a[sx][sy]=1;
        dfs(sx,sy);
        
        printf("%d\n",sum);
    }
    return 0;
} 

 

上一篇:28-样式优先级


下一篇:Jquery选择器