【POJ 1442 --- Black Box】大根堆和小根堆,优先队列
Description
Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions:
ADD (x): put element x into Black Box;
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.
Let us examine a possible sequence of 11 transactions:
Example 1
N Transaction i Black Box contents after transaction Answer
(elements are arranged by non-descending)
1 ADD(3) 0 3
2 GET 1 3 3
3 ADD(1) 1 1, 3
4 GET 2 1, 3 3
5 ADD(-4) 2 -4, 1, 3
6 ADD(2) 2 -4, 1, 2, 3
7 ADD(8) 2 -4, 1, 2, 3, 8
8 ADD(-1000) 2 -1000, -4, 1, 2, 3, 8
9 GET 3 -1000, -4, 1, 2, 3, 8 1
10 GET 4 -1000, -4, 1, 2, 3, 8 2
11 ADD(2) 4 -1000, -4, 1, 2, 2, 3, 8
It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.
Let us describe the sequence of transactions by two integer arrays:
-
A(1), A(2), …, A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).
-
u(1), u(2), …, u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, … and N-transaction GET. For the Example we have u=(1, 2, 6, 6).
The Black Box algorithm supposes that natural number sequence u(1), u(2), …, u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u§ <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), …, A(u§) sequence.
Input
Input contains (in given order): M, N, A(1), A(2), …, A(M), u(1), u(2), …, u(N). All numbers are divided by spaces and (or) carriage return characters.
Output
Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
Sample Input
7 4
3 1 -4 2 8 -1000 2
1 2 6 6
Sample Output
3
3
1
2
题意
给定一个序列,每次插入其中的一个数,给出另一个序列,序列中的第k个数表示插入第一个序列的第几个数的时候输出第k小的数,因为每插入一个数后都要让数据有序,因此用到了优先队列
解题思路
用到两个堆,一个最大堆,一个最小堆。其中最大堆用来维护,最小堆用来求k小数。
AC代码:
#include <iostream>
#include <queue>
#include <algorithm>
using namespace std;
const int MAXN = 30005;
int arr[MAXN];
priority_queue<int,vector<int>,less<int> > q_small;
priority_queue<int,vector<int>,greater<int> > q_big;
int main()
{
std::ios::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
int n,m;
cin >> n >> m;
for(int i=1;i<=n;i++)
cin >> arr[i];
int k=1;
for(int i=1;i<=m;i++)
{
int x;
cin >> x;
while(k<=x)
{
q_big.push(arr[k]);
if(!q_small.empty() && q_small.top()>q_big.top()) {
int t=q_small.top();
q_small.pop();
q_big.push(t);
t=q_big.top();
q_big.pop();
q_small.push(t);
}
k++;
}
cout << q_big.top() << endl;
int t=q_big.top();
q_big.pop();
q_small.push(t);
}
return 0;
}