hdu 1097 A hard puzzle 快速幂取模

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1097

分析:简单题,快速幂取模, 由于只要求输出最后一位,所以开始就可以直接mod10.

/*A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33036 Accepted Submission(s): 11821 Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise. Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30) Output
For each test case, you should output the a^b's last digit number. Sample Input
7 66
8 800 Sample Output
9
6 Author
eddy
*/
//快速幂取模
#include <cstdio>
#include <cstring>
int main()
{
int a, b;
while(~scanf("%d%d", &a, &b)){
a = a % ;
int cnt = ;
while(b > ){
if(b % == ) cnt = cnt*a%;
b = b/;
a = a*a%;
}
printf("%d\n", cnt);
}
return ;
}
上一篇:vim(vi)下的三种模式及其相关命令


下一篇:(转)Java程序员应该知道的10个调试技巧