Cup
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7077 Accepted Submission(s): 2177
Problem Description
The
WHU ACM Team has a big cup, with which every member drinks water. Now,
we know the volume of the water in the cup, can you tell us it height?
WHU ACM Team has a big cup, with which every member drinks water. Now,
we know the volume of the water in the cup, can you tell us it height?
The radius of the cup's top and bottom circle is known, the cup's height is also known.
Input
The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each
test case is on a single line, and it consists of four floating point
numbers: r, R, H, V, representing the bottom radius, the top radius, the
height and the volume of the hot water.
Each
test case is on a single line, and it consists of four floating point
numbers: r, R, H, V, representing the bottom radius, the top radius, the
height and the volume of the hot water.
Technical Specification
1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.
Output
For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
Sample Input
1
100 100 100 3141562
100 100 100 3141562
Sample Output
99.999024
Source
解析:二分。
#include <cstdio>
#include <cmath> const double PI = acos(-1.0);
int T;
double r,R,H,V; int main()
{
scanf("%d", &T);
while(T--){
scanf("%lf%lf%lf%lf", &r, &R, &H, &V);
double low = , high = H;
double mid;
while(high-low>1e-){
mid = (low+high)/;
double mid_r = mid/H*(R-r)+r;
double mid_v = PI/*mid*(r*r+r*mid_r+mid_r*mid_r);
if(mid_v<V)
low = mid+1e-;
else
high = mid-1e-;
}
mid = (low+high)/;
printf("%.6f\n", mid);
}
return ;
}