Date:2022.02.04
题意:
给定一个正整数 n,请你找到一个它的非零倍数 m。
要求 m 中只包含数字 0 或 1,并且总位数不超过 100 位。
输入格式
输入包含多组测试数据。
每组数据占一行,包含一个正整数 n。
当输入 n=0 时,表示输入结束。
输出格式
每组数据输出一行 m。
如果方案不唯一,则输出任意合理方案均可。
数据范围
1≤n≤200
输入样例:
2
6
19
0
输出样例:
10
100100100100100100
111111111111111111
思路:n只有200很小,因此开始便有个猜想:每个都找最小的倍数,是不是最大的那一个都不会爆LL?脑海闪过没这样写,想正解写,写了半天高精取模、dfs。结果猜想是对的- -,白给了。
代码如下:
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
typedef long long LL;
int main()
{
LL n;
while(cin>>n,n)
{
queue<LL>q;q.push(1);
while(q.size())
{
LL t=q.front();q.pop();
if(t%n==0) {cout<<t<<endl;break;}
q.push(t*10+1);
q.push(t*10);
}
}
return 0;
}