如花美眷,似水流年,回得了过去,回不了当初。
给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....
这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT
的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:
pcTclnGloRgLrtLhgljkLhGFauPewSKgt
输出样例:
GPLTGPLTGLTGLGLL
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
string s;
int main()
{
getline(cin,s);
int i=0;
int a[5]= {0};
while(s[i]!='\0')
{
if(s[i]=='G'||s[i]=='g') a[1]++;
if(s[i]=='P'||s[i]=='p') a[2]++;
if(s[i]=='L'||s[i]=='l') a[3]++;
if(s[i]=='T'||s[i]=='t') a[4]++;
i++;
}
while(1)
{
if(a[1]!=0)
{
printf("G");
a[1]--;
}
if(a[2]!=0)
{
printf("P");
a[2]--;
}
if(a[3]!=0)
{
printf("L");
a[3]--;
}
if(a[4]!=0)
{
printf("T");
a[4]--;
}
if(a[1]==0&&a[2]==0&&a[3]==0&&a[4]==0)
break;
}
return 0;
}