题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805449625288704
题目描述
Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
输入
Each input file contains one test case. Each case gives a positive integer N (≤10^4 ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
输出
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.
样例输入
5 32 321 3214 0229 87
样例输出
22932132143287
代码
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
const int maxn = 100010;
string str[maxn];
bool cmp(string a, string b) {
return a + b < b + a; //如果a + b < b + a;就把a排在前面!
}
int main() {
int n;
cin>>n;
for(int i = 0; i < n; i++)
cin>>str[i];
sort(str, str + n, cmp);
string ans;
for(int i = 0; i < n; i++) {
ans += str[i];
}
while(ans.size() != 0 && ans[0] == '0') //只需除去拼接后开头的0;
ans.erase(ans.begin());
if(ans.size() == 0)
cout<< 0;
else
cout<< ans;
return 0;
}