L2-005 集合相似度

https://pintia.cn/problem-sets/994805046380707840/problems/994805070149828608

给定两个整数集合,它们的相似度定义为:Nc/Nt*100%。其中Nc是两个集合都有的不相等整数的个数,Nt是两个集合一共有的不相等整数的个数。你的任务就是计算任意一对给定集合的相似度。

输入格式:

输入第一行给出一个正整数N(<=50),是集合的个数。随后N行,每行对应一个集合。每个集合首先给出一个正整数M(<=104),是集合中元素的个数;然后跟M个[0, 109]区间内的整数。

之后一行给出一个正整数K(<=2000),随后K行,每行对应一对需要计算相似度的集合的编号(集合从1到N编号)。数字间以空格分隔。

输出格式:

对每一对需要计算的集合,在一行中输出它们的相似度,为保留小数点后2位的百分比数字。

输入样例:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
输出样例:
50.00%
33.33%


最后一个测试点90s
如果用set而不用unordered_set,最后一个测试点169s

如果用cin代替scanf最后一个测试点159s
cin基础上+ios::sync_with_stdio(false); 81s

所以加不加这些对时间几乎都没影响,关键还是在算法。

#include <iostream>
#include <unordered_set>
using namespace std;

const int maxn = 55;
int n, k;
unordered_set<int> s[maxn];

double checksim(int a, int b)
{
    double nc = 0.0, nt = 0.0;
    for (auto x : s[a])
    {
        if (s[b].count(x))
            nc++;
    }
    nt = s[a].size() + s[b].size() - nc;
    return nc / nt * 100;
}

int main()
{
    scanf("%d", &n);
    for (int i = 1; i <= n; i++)
    {
        int m;
        cin >> m;
        for (int j = 1; j <= m; j++)
        {
            int num;
            scanf("%d", &num);
            s[i].insert(num);
        }
    }

    scanf("%d", &k);
    while (k--)
    {
        int a, b;
        scanf("%d%d", &a, &b);
        printf("%.2f%c\n", checksim(a, b), '%');
    }
    return 0;
}
上一篇:day 87 Vue学习六之axios、vuex、脚手架中组件传值


下一篇:增强for