在社交网络中,个人或单位(结点)之间通过某些关系(边)联系起来。他们受到这些关系的影响,这种影响可以理解为网络中相互连接的结点之间蔓延的一种相互作用,可以增强也可以减弱。而结点根据其所处的位置不同,其在网络中体现的重要性也不尽相同。
“紧密度中心性”是用来衡量一个结点到达其它结点的“快慢”的指标,即一个有较高中心性的结点比有较低中心性的结点能够更快地(平均意义下)到达网络中的其它结点,因而在该网络的传播过程中有更重要的价值。在有N个结点的网络中,结点vi 的“紧密度中心性”Cc(vi )数学上定义为vi 到其余所有结点vj (j≠i) 的最短距离d(vi ,vj )的平均值的倒数:
对于非连通图,所有结点的紧密度中心性都是0。
给定一个无权的无向图以及其中的一组结点,计算这组结点中每个结点的紧密度中心性。
输入格式:
输入第一行给出两个正整数N和M,其中N(≤104 )是图中结点个数,顺便假设结点从1到N编号;M(≤105 )是边的条数。随后的M行中,每行给出一条边的信息,即该边连接的两个结点编号,中间用空格分隔。最后一行给出需要计算紧密度中心性的这组结点的个数K(≤100)以及K个结点编号,用空格分隔。
输出格式:
按照Cc(i)=x.xx的格式输出K个给定结点的紧密度中心性,每个输出占一行,结果保留到小数点后2位。
输入样例:
9 14
1 2
1 3
1 4
2 3
3 4
4 5
4 6
5 6
5 7
5 8
6 7
6 8
7 8
7 9
3 3 4 9
输出样例:
Cc(3)=0.47
Cc(4)=0.62
Cc(9)=0.35
import java.util.Scanner;
import java.util.concurrent.LinkedBlockingDeque;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int vertex = sc.nextInt();
int edge = sc.nextInt();
Graph graph = new Graph(vertex, edge);
for (int i = 0; i < edge; i++) {
int temp1 = sc.nextInt();
int temp2 = sc.nextInt();
graph.Insert(temp1 - 1, temp2 - 1);
}
int num = sc.nextInt();
for (int i = 0; i < num; i++) {
int n = sc.nextInt();
System.out.format("Cc(%d)=%.2f\n",n,graph.Importance(n-1));
}
}
}
class Graph {
private int Vertex;
private int Edge;
private int[][] G;
Graph(int v, int e) {
Vertex = v;
Edge = e;
G = new int[v][v];
}
void Insert(int v1, int v2) {
G[v1][v2] = 1;
G[v2][v1] = 1;
}
double Importance(int v) {
int[] distance = new int[Vertex];
for (int i = 0; i < Vertex; i++) {
distance[i] = Integer.MAX_VALUE;
}
distance[v] = 0;
int[][] Visited = new int[Vertex][Vertex];
LinkedBlockingDeque<Integer> q = new LinkedBlockingDeque<Integer>();
q.push(v);
while(!q.isEmpty()){
int temp = q.poll();
for(int i=0;i<Vertex;i++){
if(G[temp][i]==1&&Visited[temp][i]==0){
if(distance[i]>distance[temp]+1)
distance[i] = distance[temp]+1;
q.add(i);
Visited[temp][i] = 1;
Visited[i][temp] = 1;
}
}
}
double sum = 0;
for (int i = 0; i < Vertex; i++) {
if (distance[i] != Integer.MAX_VALUE) {
sum += distance[i];
}
}
return (Vertex - 1.0) / sum;
}
}