Hdu1896 Stones(优先队列) 2017-01-17 13:07 40人阅读 评论(0) 收藏

Stones

Time Limit : 5000/3000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 41   Accepted Submission(s) : 34

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 

There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell
me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 

For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position
of the i-th stone and how far Sempr can throw it.

Output

Just output one line for one test case, as described in the Description.

Sample Input

2
2
1 5
2 4
2
1 5
6 6

Sample Output

11
12

———————————————————————————————————————————————————————————————————————————

题目说在一条直线道路上有n个石头,往前走,遇到一个数一个,如果遇到的是第奇数个那就把这个石头往前扔距离D[i], 如果是第偶数个,就放置不管。

问遇到的最后一个石头距离出发点的位置是多少。





做起来也比较简单就是每遇到第奇数个石头,就将其加上D[i],放回到优先队列中,然后再去掉一个石头

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std; struct node
{
int x, t;
}; struct cmp
{
bool operator () (const node a, const node b)
{
if(a.x != b.x)return a.x > b.x;
else return a.t > b.t;
}
}; int main()
{
    int o,n;
priority_queue<node,vector<node>,cmp>q;
node a[100005],k;
scanf("%d",&o);
while(o--)
{
    while(!q.empty())
        q.pop();
scanf("%d",&n);
for(int i=0;i<n;i++)
{
    scanf("%lld%d",&a[i].x,&a[i].t);
    q.push(a[i]);
}
while(!q.empty())
{
    k=q.top();
    q.pop();
    k.x+=k.t;
    q.push(k);
    q.pop();
}
printf("%d\n",k.x);
}
    return 0;
}
上一篇:《SteamVR实战之PMCore》(Yanlz+Unity+XR+SteamVR+VR+AR+MR+Valve+Oculus+立钻哥哥+==)


下一篇:贪心+优先队列之更改优先级-hdu1896