Oil Deposits HDU - 1241

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@
@
@@**@
0 0
Sample Output
0
1
2
2
翻译:
GeoSurvComp地质调查公司负责探测地下石油储藏。 GeoSurvComp现在在一块矩形区域探测石油,并把这个大区域分成了很多小块。他们通过专业设备,来分析每个小块中是否蕴藏石油。如果这些蕴藏石油的小方格相邻,那么他们被认为是同一油藏的一部分。在这块矩形区域,可能有很多油藏。你的任务是确定有多少不同的油藏。

Input
输入可能有多个矩形区域(即可能有多组测试)。每个矩形区域的起始行包含m和n,表示行和列的数量,1<=n,m<=100,如果m =0表示输入的结束,接下来是n行,每行m个字符。每个字符对应一个小方格,并且要么是’*’,代表没有油,要么是’@’,表示有油。

Output
对于每一个矩形区域,输出油藏的数量。两个小方格是相邻的,当且仅当他们水平或者垂直或者对角线相邻(即8个方向)。

Sample Input

1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@
@
@@**@
0 0

Sample Output
0
1
2
2
题解:

#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string.h>
#include<string>
using namespace std;
int map1[8][2]={0,1,0,-1,1,0,-1,0,1,1,-1,-1,1,-1,-1,1};
int INF = 0x3f3f3f3f;
int n,m;
int x,y;
int a,b;
char s[125][125];
void dfs(int x,int y)
{
   s[x][y]='*';
   for(int i=0;i<8;i++)
   {
       int a=x+map1[i][0];
       int b=y+map1[i][1];
       if(a>=0&&a<n&&b>=0&&b<m&&s[a][b]=='@')
      dfs(a,b);
   }
}
int main()
{

    int sum;
   while(cin>>n>>m&&n&&m)
   {
       sum=0;
       memset(s,0,sizeof(s));
       for(int i=0;i<n;i++)
       {
           for(int j=0;j<m;j++)
           {
               cin>>s[i][j];
           }
       }
      for(int i=0;i<n;i++)
       {
           for(int j=0;j<m;j++)
           {
              if(s[i][j]=='@')
              {
                  dfs(i,j);
                  sum++;
              }
           }
       }
       cout<<sum<<endl;
       sum=0;


   }

    return 0;
}
上一篇:数据湖(Data Lake)-剑指下一代数据仓库


下一篇:数据湖(Data Lake)-剑指下一代数据仓库