【进制问题】【HDU2056】A + B Again

A + B Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15772    Accepted Submission(s): 6847

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.

Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.

Easy ? AC it !
 
Input
The input contains several test cases, please process to the end of the file.

Each case consists of two hexadecimal integers A and B in a line seperated by a blank.

The length of A and B is less than 15.
 
Output
For each test case,print the sum of A and B in hexadecimal in one line.
 
Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA
 
Sample Output
0
2C
11
-2C
-90
 
Author
linle
 
Source

1.%I64X 输入

2.%I64X 不能输出负数

3.%I64O 也不能输出负数

4.如果x 为小写 输出的16进制为小写,为大写,输出大写

#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <ctime>
#include <algorithm>
#include <iostream>
#include <sstream>
#include <string>
#define oo 0x13131313
using namespace std;
int main()
{
long long A;long long B;
while(scanf("%I64O%I64O",&A,&B)!=EOF)
{
long long C=A+B;
// if(C<0)
// printf("-%I64X\n",-C);
printf("%I64o\n",C);
}
return 0;
}
上一篇:用tcpdump分析tcp三次握手,四次挥手


下一篇:mfc对话框启动就直接隐藏在右下角显示托盘图标