hdu1002 A + B Problem II(高精度加法) 2016-05-19 12:00 106人阅读 评论(0) 收藏

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 308484    Accepted Submission(s): 59635

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.
 
Sample Input
2
1 2
112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3 Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
 
-----------------------------------------------------------------------------------------------------------------------------------------------
高精度加法计算,数值位数太大,用字符处理,按位计算,为了方便末尾对齐,采取先取反再相加在取反;
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
using namespace std;
void un(char *a,int k) //取反
{
for(int i=0;i<k/2;i++)
swap(a[i],a[k-1-i]);
}
int main()
{
char a[1005],b[1005],c[1005],A[1005],B[1005];
int k1,k2,k;
int o;
while(~scanf(" %d",&o))
{
int t=0;
int q=o;
while(o--)
{
memset(c,'0',sizeof(c));
scanf(" %s %s",A,B);
strcpy(a,A);
strcpy(b,B);
k1=strlen(a);
k2=strlen(b);
un(a,k1);
un(b,k2);
if(k1>k2)//补零以对齐;
{
k=k1;
for(int i=k2;i<k;i++)
b[i]='0';
}
else
{
k=k2;
for(int i=k1;i<k;i++)
a[i]='0'; }
for(int i=0;i<k;i++)//相加和进位
{
c[i]=c[i]+(a[i]-'0')+(b[i]-'0');
if(c[i]>'9')
{
c[i]-=10;
c[i+1]+=1;
}
}
printf("Case %d:\n%s + %s = ",++t,A,B);
if(c[k]>'0') //最高位进位单独考虑
printf("%c",c[k]);
for(int i=k-1;i>=0;i--)
{
printf("%c",c[i]);
}
printf("\n");
if(t!=q)
printf("\n");
} }
return 0;
}

上一篇:nyoj 623 A*B Problem II(矩阵)


下一篇:hdu1002 A + B Problem II(大数题)