Text Reverse

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13524    Accepted Submission(s): 5161

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 
Output
For each test case, you should output the text which is processed.
 
Sample Input
3
olleh !dlrow
m'I morf .udh
I ekil .mca
 
Sample Output
hello world! I'm from hdu. I like acm.

思路:字符串处理,注意细节,容易出错。

#include<stdio.h>
#include<string.h>
char str[],temp[],*p;
int
main()
{

int
n,i,j;
scanf("%d",&n);
getchar();
while
(n--)
{

memset(str,,sizeof(str));
gets(str);
p = str;
i =;
while
(*p!='\0')
{

if
(*p!=' ')
{

temp[i++] = *p;
if
(*(p+)==' ')
temp[] = ' ';
}

else

{

for
(j = i -;j >=;j --)
printf("%c",temp[j]);
i =;
}

if
(*(p+)=='\0')
{

for
(j = i -;j >;j --)
printf("%c",temp[j]);
}

p++;
}

printf("\n");
}

return
;
}
上一篇:HTML中的uniqueID


下一篇:C#扩展方法(转)