给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
后序 左右根 2,3,1,|5,7,6,|4 4是根
中序 左根右 1,2,3,|4,|5,6,7 在4左边是4的左子树在4右边是4的右子树
把左右子树分别再处理就构建了树
后 2 3 1
中1 2 3 2 3都是1的右子树.......................
#include<bits/stdc++.h>
using namespace std;
struct tree{
int l,r;
}t[1001];
int n;
int a[50],b[50];
int dfs(int x,int y,int x1,int y1){//后中确定树
if(x>y)
return 0;
int r=a[y];
int i=x1;
while(b[i]!=r) i++;
//cout<<r<<endl;
t[r].l=dfs(x,x+i-x1-1,x1,i-1);
t[r].r=dfs(x+i-x1,y-1,i+1,y1);
return r;
}
void bfs(int r){//层次遍历
queue<int> q;
q.push(r);
vector <int>z;
while(!q.empty()){
int a=q.front();
//cout<<a<<" ";
z.push_back(a);
q.pop();
if(t[a].l!=0){
q.push(t[a].l);
}
if(t[a].r!=0){
q.push(t[a].r);
}
}
for(int i=0;i<z.size()-1;i++){
cout<<z[i]<<" ";
}
cout<<z[z.size()-1];
return ;
}
int main(){
cin>>n;
for(int i=0;i<n;i++){
cin>>a[i];
}
for(int i=0;i<n;i++){
cin>>b[i];
}
dfs(0,n-1,0,n-1);
int k=a[n-1];
bfs(k);
return 0;
}