7-1 球队“食物链” (30 分)
某国的足球联赛中有N支参赛球队,编号从1至N。联赛采用主客场双循环赛制,参赛球队两两之间在双方主场各赛一场。
联赛战罢,结果已经尘埃落定。此时,联赛主席突发奇想,希望从中找出一条包含所有球队的“食物链”,来说明联赛的精彩程度。“食物链”为一个1至N的排列{ T1 T2 ⋯ TN },满足:球队T1战胜过球队T2,球队T2战胜过球队T3,⋯,球队T(N−1)战胜过球队TN,球队TN战胜过球队T1。
现在主席请你从联赛结果中找出“食物链”。若存在多条“食物链”,请找出字典序最小的。
注:排列{ a1 a2 ⋯ aN}在字典序上小于排列{ b1 b2 ⋯ bN },当且仅当存在整数K(1≤K≤N),满足:aK<bK且对于任意小于K的正整数i,ai=bi。
输入格式:
输入第一行给出一个整数N(2≤N≤20),为参赛球队数。随后N行,每行N个字符,给出了N×N的联赛结果表,其中第i行第j列的字符为球队i在主场对阵球队j的比赛结果:W表示球队i战胜球队j,L表示球队i负于球队j,D表示两队打平,-表示无效(当i=j时)。输入中无多余空格。
输出格式:
按题目要求找到“食物链”T1 T2 ⋯ TN,将这N个数依次输出在一行上,数字间以1个空格分隔,行的首尾不得有多余空格。若不存在“食物链”,输出“No Solution”。
输入样例1:
5
-LWDW
W-LDW
WW-LW
DWW-W
DDLW-
输出样例1:
1 3 5 4 2
输入样例2:
5
-WDDW
D-DWL
DD-DW
DDW-D
DDDD-
输出样例2:
No Solution
收获:
1 因为只用输出一条结果,所以按字典顺序进行遍历即可。
2 递归就是最好的栈,不用自己写栈
3 本道题输入不合法,要考虑多种情况,即程序的健壮性
4 不要用变量声明数组
5 当递归某一种情况得出结果时,要设置tag,让其他的递归直接返回
6 本道题严格最后的输出结果,对空格和换行要求很严格
//自己最后写出来的代码
//You need consider two situations ('W' or 'L')
//The Recrusion is the best useful stack
#include<iostream>
using namespace std;
int n;
char ch;
int a[21][21]={0}; //Don't use variable to declare others.
int arr[21]={0};
int visited[21]={0};
int curLong = 0;
int ans = 0;
void dfs(int v){
if(ans==1){//Here is succes but last layer may run continue.
return;
}
if(curLong==n&&( a[v][0] == 1 || a[0][v] == -1)){// You transfer last i to here
ans=1;
return;
}
int tag = 0;
for(int i=0;i<n;i++){
if(!visited[i]){
if(a[i][0]==1||a[0][i]==-1){
tag=1;
}
}
}
if(tag==0){
return;
}
for(int i=0;i<n;i++){
if( !visited[i] && ( a[v][i] == 1 || a[i][v] == -1 )){
arr[curLong]=i;
visited[i]=1;
curLong++;
dfs(i);
if(ans==1){
return;
}
visited[i]=0;
curLong--;
}
}
}
int main(){
cin>>n;
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
cin>>ch;
if(ch=='W'){
a[i][j]=1;
}else if(ch=='L'){
a[i][j] = -1;
}else{
a[i][j] = 0;
}
}
}
arr[curLong]=0;
visited[0]=1;
curLong++;
dfs(0);
if(ans==1){
for(int i=0;i<n-1;i++){
cout<<arr[i]+1<<" ";
}
cout<<arr[n-1]+1<<endl;
}else{
cout<<"No Solution\n";
}
return 0;
}
//参考的答案代码
//注意:i战胜j可以是st[i][j]='W'||st[j][i]='L';
#include<stdio.h>
#include<string.h>
int n;
char st[25][25];
int a[25];
int ans;
int l;
int visit[25];
int u;
void dfs(int v)
{
int i,j;
if(ans==1)
return ;
if(l==n)
{
if(st[v][u]=='W'||st[u][v]=='L')
{
for(j=0;j<n-1;j++)
printf("%d ",a[j]+1);
printf("%d\n",a[n-1]+1);
ans=1;
return ;
}
}
for(i=0;i<n;i++)
{
if(ans==1)
return ;
int tag=0;
//优化,因为是一个环,若该点没有战胜0,则就没有必要对该点判断下去
for(j=1;j<n;j++)
{
if(!visit[j]&&st[j][0]=='W'||st[0][j]=='L')
{
tag=1;
break;
}
}
if(tag==0)
return ;
if(!visit[i]&&(st[v][i]=='W'||st[i][v]=='L'))
{
visit[i]=1;
a[l]=i;
l++;
dfs(i);
visit[i]=0;
l--;
}
}
}
int main()
{
int i,j;
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%s",st[i]);
int tag=0;
// //优化,因为是一个环,所以若存在一个食物链,就直接判断从0开始是否可以即可
// for(i=1;i<n;i++)
// {
// if(st[i][0]=='W'||st[0][i]=='L')
// {
// tag=1;
// break;
// }
// }
// if(tag==0)
// {
// printf("No Solution\n");
// return 0;
// }
memset(visit,0,sizeof(visit));
ans=0;
l=0;
u=0;
a[l]=0;
l++;
visit[0]=1;
dfs(0);
if(ans==0)
printf("No Solution\n");
return 0;
}
//自己对答案代码进行了修改 7-1 球队“食物链” (30 分)
//注意:i战胜j可以是st[i][j]='W'||st[j][i]='L';
#include<stdio.h>
#include<string.h>
int n;//The number of Teams
char st[25][25];//The game results
int a[25]; //Mark the number of everyteam
int ans; //answer
int l; //The current long
int visit[25]; //If it is visited
void dfs(int v)
{
int i,j;
if(ans==1)
return ;
if(l==n)
{
if(st[v][0]=='W'||st[0][v]=='L')//The right answer if there is a loop the 1 must be the first
{
for(j=0;j<n-1;j++)//Two statement of printf to assure the format
printf("%d ",a[j]+1);
printf("%d\n",a[n-1]+1);
ans=1; //To assure don't output No solution
return ;
}
}
for(i=0;i<n;i++)
{
//To prevent overtime begin
// int tag=0;
// //优化,因为是一个环,若该点没有战胜0,则就没有必要对该点判断下去
// //If 0 win others all.
// for(j=1;j<n;j++)
// {
// if(!visit[j]&&st[j][0]=='W'||st[0][j]=='L')
// {
// tag=1;
// break;
// }
// }
// if(tag==0)
// return ;
//I think that 0 or 1 is all right, but if you change the 0 to 1,
//To prevent overtime end
if(!visit[i]&&(st[v][i]=='W'||st[i][v]=='L'))
{
visit[i]=1;
a[l]=i;
l++;
dfs(i);
visit[i]=0;
l--;
}
}
}
int main()
{
int i,j;
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%s",st[i]);
int tag=0;
memset(visit,0,sizeof(visit));
ans=0; //answer=0
l=0;
a[l]=0;
l++; // The current long of teams
visit[0]=1; //The first is visited
dfs(0);
if(ans==0)
printf("No Solution\n");
return 0;
}