1 2 3 4
5 6 7 8
9 10 11 12
13 14 15 x
where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4
5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8
9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12
13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x
r-> d-> r->
The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.
Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).
In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three arrangement.
Input
1 2 3
is described by this list:
1 2 3 x 4 6 7 5 8
Output
Sample Input
Sample Output
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<set>
#include<map>
#include<queue>
#include<vector>
#include<iterator>
#include<utility>
#include<sstream>
#include<iostream>
#include<cmath>
#include<stack>
using namespace std;
const int INF=1000000007;
const double eps=0.00000001;
int dx[]={-1,0,1,0},dy[]={0,-1,0,1}; //方向数组
char dir[]={'d','r','u','l'}; //方向数组对应的相反方向的字符,由于是逆向打表
int fa[363000],fact[10]; //fa[]保存父亲状态的编号,fact[i]=i!
string ans[363000]; /对应的打印路径
int Cul(int n)
{
int ret=1;
for(int st=1;st<=n;st++) ret*=st;
return ret;
}
int id(int B[]) //得到编号
{
int ret=0;
for(int i=0;i<9;i++)
{
int less=0;
for(int j=i+1;j<9;j++) if(B[j]<B[i]) less++;
ret+=fact[9-1-i]*less;
}
return ret;
}
bool in(int x,int y){return x>=0&&x<3&&y>=0&&y<3;} //判断是否在界内
struct node
{
int x,y,ID; //坐标,id值,此时的状态数组
int A[9];
};
int main()
{
for(int i=0;i<10;i++) fact[i]=Cul(i);
for(int i=0;i<363000;i++) ans[i].clear();
node st;
st.x=2,st.y=2,st.ID=0;
for(int i=0;i<3;i++)
for(int j=0;j<3;j++) st.A[i*3+j]=i*3+j+1; //终末状态
memset(fa,-1,sizeof(fa));
fa[0]=0;
queue<node> que;
que.push(st);
while(!que.empty())
{
node now=que.front(); que.pop();
for(int op=0;op<4;op++)
{
node t=now;
t.x+=dx[op],t.y+=dy[op];
if(in(t.x,t.y))
{
swap(t.A[now.x*3+now.y],t.A[t.x*3+t.y]); //交换位置
int I=id(t.A);
if(fa[I]==-1) //没有被访问过
{
t.ID=I;
que.push(t);
fa[I]=now.ID;
ans[I]=dir[op]+ans[now.ID]; // 得到路径
}
}
}
}
string S;
while(getline(cin,S))
{
int rear[9],cnt=0;
istringstream out(S);
string single;
while(out>>single)
if(single=="x") rear[cnt++]=9;
else rear[cnt++]=single[0]-'0';
int I=id(rear);
if(fa[I]!=-1) cout<<ans[I]<<endl;
else cout<<"unsolvable"<<endl;
}
return 0;
}