7-5 带密码的约瑟夫问题
带密码的约瑟夫问题:编号为1,2,......,n的n个人按照顺时针方向围坐一圈,每个人有自己的编号(正整数)、姓名和密码(正整数)三个数据项。一开始任选一个正整数作为报数上限值,从第一个人开始顺时针方向自1开始报数,报到m时停止报数。报m 的人出列,将他的密码作为新的m值,从他在顺时针方向的下一个人开始重新报数,如此下去,直到所有人全部出队为止。设计一个程序来求出出队顺序。
输入格式:
输入人数 n(1≤n≤50),再逐行输入每个人的信息(各项之间用逗号隔开),然后输入报数上限值m。
输出格式:
按出队顺序逐行输出每个人的信息,每人信息一行,数据项之间用逗号隔开
输入样例:
在这里给出一组输入。例如:
5
1,刘三,3
2,李丽,5
3,吴勇,8
4,钱多,2
5,齐民,4
2
输出样例:
在这里给出相应的输出。例如:
2,李丽,5
3,吴勇,8
5,齐民,4
4,钱多,2
1,刘三,3结尾无空行
为了完成数据结构报告写出来的东西
#include<iostream>
#include<iomanip>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<malloc.h>
using namespace std;
typedef struct MyList
{
int num;
char name[10];
int code;
struct MyList *next;
}MyList,*List;
int main()
{
List L;
L=(List)malloc(sizeof(MyList));
L->next=NULL;
int n,ciallo1,ciallo3;
char ciallo2[10];
List a=L,b;
cin>>n;
for(int i=0;i<n;i++)
{
b=(List)malloc(sizeof(MyList));
scanf("%d,%[^,],%d", &ciallo1, ciallo2, &ciallo3);
b->num=ciallo1;
strcpy(b->name,ciallo2);
b->code=ciallo3;
b->next=NULL;
a->next=b;
a = b;
}
b->next=L;
int m=0;
cin>>m;
int count=0;
List c=L;
while(count<n)
{
for(int i=0;i<m;i++)
{
c=c->next;
while(c==L||c->num==0)
{
c=c->next;
}
}
cout<<c->num<<","<<c->name<<","<<c->code;
if(count!=n-1)
{
cout<<"\n";
}
c->num=0;
m=c->code;
count++;
}
return 0;
}