Description
Lacking even a fifth grade education, the cows are having trouble with a fraction problem from their textbook. Please help them. The problem is simple: Given a properly reduced fraction (i.e., the greatest common divisor of the numerator and denominator is 1, so the fraction cannot be further reduced) find the smallest properly reduced fraction with numerator and denominator in the range 1..32,767 that is closest (but not equal) to the given fraction. 找一个分数它最接近给出一个分数. 你要找的分数的值的范围在1..32767
Input
* Line 1: Two positive space-separated integers N and D (1 <= N < D <= 32,767), respectively the numerator and denominator of the given fraction
Output
* Line 1: Two space-separated integers, respectively the numerator and denominator of the smallest, closest fraction different from the input fraction.
Sample Input
Sample Output
OUTPUT DETAILS:
21845/32767 = .666676839503.... ~ 0.666666.... = 2/3.
题意是给定一个分数a/b,求和它最接近的分数x/y。只要限制1<=x,y<=32767就行了
我们从1到32767枚举分母j,然后显然和a/b最相近的分数一定是i/j和(i+1)/j。至于怎么算自己脑补一下就行,很简单
有一个问题是判定i/j和a/b是否完全相等,如果怕被卡精度可以直接判定(i*b==j*a)是否成立就行了。这也很简单,就是移项一下
然后没有了
#include<cstdio>
#include<cmath>
int a,b,i,aa,bb;
double save=10;
inline double abs(double x)
{if (x<0)x=-x;return x;}
void jud(int x,int y)
{
if (x*b==y*a) return;
double work=abs((double)x/y-(double)a/b);
if (work<save)
{
save=work;
aa=x;
bb=y;
}
}
int main()
{
scanf("%d%d",&a,&b);
for (int j=1;j<=32767;j++)
{
i=(int)floor((double)a/b*j);
jud(i,j);
jud(i+1,j);
}
printf("%d %d\n",aa,bb);
}