PAT乙级1008

PAT乙级1008

马上读研了,拿pat复习一下吸语言。

题目

一个数组A中存有N(>0)个整数,在不允许使用另外数组的前提下,将每个整数循环向右移M(≥0)个位置,即将A中的数据由(A0A1⋯A**N−1)变换为(A**NMA**N−1A0A1⋯A**NM−1)(最后M个数循环移至最前面的M个位置)。如果需要考虑程序移动数据的次数尽量少,要如何设计移动的方法?

输入格式:

每个输入包含一个测试用例,第1行输入N(1≤N≤100)和M(≥0);第2行输入N个整数,之间用空格分隔。

输出格式:

在一行中输出循环右移M位以后的整数序列,之间用空格分隔,序列结尾不能有多余空格。

输入样例:

6 2
1 2 3 4 5 6

输出样例:

5 6 1 2 3 4

错误

测试用例1、2未通过

#include<stdio.h>
#include<string.h>

//statement code
int i,n,m,p;
int num_list[101];

//function section
int robustness_check1(){//robustness function1

	return 0;
}
void print_result(){
	for( i = 0 ; i < n ; i++){
		printf("%d", num_list[(i+p)%n]);
		if(i != n-1){
			printf(" ");
		}
	}
}
int main(){
	//input code
	scanf("%d %d",&n,&m);
	for(i = 0 ; i < n; i++){
		int temp;
		scanf("%d",&temp);
		num_list[i] = temp;
	}
	p = n-m;
	//robustness code
	//function code
	print_result();

	return 0;
}

代码

此代码仅仅将上面代码的

printf("%d", num_list[(i+p)%n]);

修改为

printf("%d", num_list[(i+p+n*20)%n]);

目的是让括号内的数是正数。之前没有考虑m>n这种情况的发生。

后面经过测试,仅+n也是可以的。

#include<stdio.h>
#include<string.h>

//statement code
int i,n,m,p;
int num_list[101];

//function section
int robustness_check1(){//robustness function1

	return 0;
}
void print_result(){
	for( i = 0 ; i < n ; i++){
		printf("%d", num_list[(i+p+n*20)%n]);
		if(i != n-1){
			printf(" ");
		}
	}
}
int main(){
	//input code
	scanf("%d %d",&n,&m);
	for(i = 0 ; i < n; i++){
		int temp;
		scanf("%d",&temp);
		num_list[i] = temp;
	}
	p = n-m;
	//robustness code
	//function code
	print_result();

	return 0;
}

总结

  • %运算符,左边如果是负数,结果也是负数

    PAT乙级1008

  • printf中想要输出%,需要打两个%。

上一篇:2021“MINIEYE杯”中国大学生算法设计超级联赛(1)1008.Maximal submatrix


下一篇:1008: 美元和人民币