Description Consider equations having the following form:
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 The coefficients are given integers from the interval [-50,50]. It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. Determine how many solutions satisfy the given equation. Input The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.
Output The output will contain on the first line the number of the solutions for the given equation.
Sample Input 37 29 41 43 47 Sample Output 654 Source Romania OI 2002
|
题目大意:给a1, a2, a3, a4, a5,5个数且 xi∈[-50,50],xi != 0, any i∈{1,2,3,4,5}.求出有多少种解使得a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0
题解:5个for肯定会超时(1e8),可以分开考虑,移项可以得到-a1x13- a2x23= a3x33+ a4x43+ a5x53,把左边所有的可能存在数组里,右边查询即可,左边可能为负数,所以两边同时加上25001000
#include <stdio.h>
char mp[];
int main()
{
int t,i, j, k,a2, a1, a3,a4,a5;
scanf("%d%d%d%d%d", &a1, &a2, &a3, &a4, &a5);
for(j=-;j<=;j++)
for(k=-;k<=;k++)
if(j!=&&k!=)
mp[a1*j*j*j+a2*k*k*k+]++;
for(t=,i=-;i<=;i++)
for(j=-;j<=;j++)
for(k=-;k<=;k++)
if(i!=&&j!=&&k!=)
t += mp[-a3*k*k*k-i*i*i*a4-j*j*j*a5];
printf("%d\n", t);
return ;
}