Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
Sample Output
15
刚开始 在想RMQ。。。死活没想到。。看到题解后竟然是DP。。。
最大连续子序列和的题。。。。
先求每一行的前缀和,然后i,j的横向区间和为dp【k】【i】-dp【k】【j-1】;
把竖列分成n*(n-1)/2个,然后竖向进行最大连续子序列求和。。(分成这么多个子问题,不多不少全包含。)
最大值用ma存,最后输出就行,复杂度O(n^3);
就当复习DP了。。。。行吧,还是太菜不够灵活。
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
#define inf 0x3f3f3f3f
int dp[101][101];
int main()
{
int n,m;
cin>>n;
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
scanf("%d",&m);
dp[i][j]=dp[i][j-1]+m;
}
/* for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
printf(" %d ",dp[i][j]);
puts("");
}*/
int f=0,sum=0,ma=dp[1][1];
for(int i=0;i<n;i++)
for(int j=i+1;j<=n;j++)
{
sum=0;
for(int k=1;k<=n;k++)
{
f=dp[k][j]-dp[k][i];
// printf(" %d +++\n",f);
sum+=f;
ma=max(ma,sum);
if(sum<0)
sum=0;
}
}
cout<<ma<<endl;
return 0;
}
人一我百,人百我万.夕林山寸,寻梦指尖!